
 
 
 

 

 

LABORATORIUM „SYSTEMY I SIECI TELEKOMUNIKACYJNE” 

CZĘŚĆ 1 

WPROWADZENIE DO PRACY Z PROGRAMEM NCTUNS 
 



SiST Strona 2 
 

1 Charakterystyka programu NCTUns 
Program NCTUns jest zaawansowanym narzędziem umożliwiającym symulację oraz emulację 

działania sieci teleinformatycznych. W celu uzyskania jak najwierniejszych wyników modelowania 

funkcjonowania sieci, architektura programu wykorzystuje rzeczywisty stos protokołów TCP/IP 

systemu Linux. Ścisła integracja z systemem operacyjnym umożliwia także uruchamianie na węzłach 

modelowanych sieci rzeczywistych aplikacji zainstalowanych w systemie. 

Program NCTUns pozwala na prowadzenie symulacji działania sieci IP złożonych z węzłów stałych 

oraz ruchomych wykorzystujących najpopularniejsze protokoły: transportowe (TCP, UDP), warstwy 

MAC (CSMA/CD, CSMA/CA), routingu (RIP, OSPF). Pozwala na modelowanie działania urządzeń 

pracujących w standardach transmisji danych takich jak IEEE 802.11, IEEE 802.16 (WiMAX), GPRS. 

Otwarta architektura programu pozwala użytkownikowi na dodawanie własnych protokołów [2]. 

2 Uruchamianie programu NCTUns 
W celu uruchomienia programu NCTUns należy: 

- zalogować się jako użytkownik student (hasło: telekomunikacja); 

- uruchomić program Sun VirtualBox; 

- wybrać maszynę wirtualną Fedora12 i uruchomić poprzez naciśnięcie przycisku Uruchom (Rys. 1); 

- podczas uruchamiania systemu Fedora pojawi się okno wyboru jądra systemu; należy wybrać opcję 

NCTUns (2.6.31.6-nctuns20091227) i zatwierdzić decyzję poprzez naciśnięcie klawisza Enter (Rys. 2); 

- po uruchomieniu systemu należy zalogować się jako użytkownik nctuns (hasło: nctuns); 

- przed uruchomieniem klienta programu NCTUns należy uruchomić programy dispatcher oraz 

coordinator znajdujące się w katalogu /usr/local/nctuns/bin/. W celu uruchomienia wymienionych 

programów należy uruchomić terminal (skrót znajduje się na pulpicie) oraz wykonać polecenie 

./run_nctuns; 

- uruchomić program nctunsclient znajdujący się katalogu /usr/local/nctuns/bin/. Skrót do programu 

znajduje się na pulpicie; 

- po poprawnym wykonaniu wymienionych czynności powinno ukazać się okno interfejsu graficznego 

programu NCTUns (Rys. 3). 
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Rys. 1 Okno programu VirtualBox – wybór przeznaczonej do uruchomienia maszyny wirtualnej 

 

Rys. 2 Wybór jądra systemu Linux Fedora 
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Rys. 3 Interfejs graficzny programu NCTUns 
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3 Opis podstawowych elementów interfejsu programu NCTUns 
Graficzny interfejs użytkownika programu NCTUns składa się z następujących elementów: 

- menu pozwalającego na dostęp do funkcji programu (Rys. 4 – M); 

- pasków narzędzi umożliwiających m.in. definiowanie topologii sieci (ikony reprezentujące różne 

klasy urządzeń) oraz zmianę trybu działania programu (Rys. 4 – PN); 

- obszaru roboczego, w którym definiuje się topologię analizowanej sieci (Rys. 4 – OR); 

- pasku statusu, w którym wyświetlane są informacje dotyczące przebiegu symulacji oraz znajdują się 

przyciski umożliwiające sterowanie odtwarzaniem wyników symulacji (Rys. 4 – ST). 

ST

PN

M

OR

 

Rys. 4 Główne elementy interfejsu graficznego programu NCTUns 
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4 Rozpoczynanie pracy z programem NCTUns 
Praca nad projektem sieci dzieli się na cztery etapy, z którymi powiązane są odpowiednie tryby 

działania programu: 

- etap rysowania topologii sieci (przycisk D na pasku narzędzi  lub menu File->Operating 

Mode->Draw Topology); 

- etap określania parametrów elementów sieci (przycisk E na pasku narzędzi  lub menu  

File->Operating Mode->Edit Property); 

- etap symulacji działania sieci (przycisk R na pasku narzędzi  lub menu File->Operating 

Mode->Run Simulation); 

- etap odtwarzania i wizualizacji wyników symulacji (przycisk P na pasku narzędzi  lub menu  

File->Operating Mode->Play Back). 

 

W celu otworzenia istniejącego projektu sieci należy wybrać menu File->Open a następnie wskazać 

położenie pliku projektu (.tpl). 

W celu utworzenia projektu nowej sieci należy wybrać menu File->New. Po utworzeniu nowego 

projektu na ekranie pokaże się pusty obszar roboczy, na którym można umieszczać elementy 

modelowanej sieci. W celu umieszczenia elementu sieci w obszarze roboczym należy upewnić się, że 

program jest w trybie definiowania topologii sieci (przycisk D na pasku narzędzi  lub menu 

File->Operating Mode->Draw Topology) a następnie wybrać element sieci z paska narzędzi, wskazać 

kursorem docelowe miejsce w obszarze roboczym i kliknąć lewym przyciskiem myszy. 

Po zdefiniowaniu topologii modelowanej sieci należy przejść do kolejnego etapu, w którym określone 

zostaną bardziej zaawansowane parametry węzłów sieci. W tym celu należy zmienić tryb pracy 

programu na tryb określania parametrów elementów sieci (przycisk E na pasku narzędzi  lub 

menu File->Operating Mode->Edit Property). W wyniku zmiany trybu pracy, program poprosi o 

wskazanie położenia i podanie nazwy pliku projektu oraz automatycznie wygeneruje podstawowe 

ustawienia sieci, m.in. adresy IP urządzeń. W tym trybie pracy programu można określić bardziej 

zaawansowane parametry pracy urządzeń. Należą do nich m.in.: 

− opóźnienia i stopy błędów w łączach transmisyjnych; 

− aplikacje (generatory ruchu) działające na poszczególnych węzłach sieci; 

− protokoły routingu; 

− wielkości buforów; 

− parametry pracy zapisywane do plików dziennika; 

− czasy włączenia/wyłączenia urządzeń. 
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Dostęp do ustawień podstawowych parametrów urządzeń uzyskuje się poprzez wskazanie kursorem 

ikony urządzenia i podwójne kliknięcie lewym przyciskiem myszy (Rys. 5).  

 

Rys. 5 Okno definiowania parametrów węzła typu host - definiowanie aplikacji (ustawień generatorów ruchu) 

Poprzez naciśnięcie przycisku Node editor można uzyskać dostęp do bardziej zaawansowanych 

ustawień (Rys. 6). Wybierając np. prostokąt reprezentujący warstwę MAC 802.3 można m.in. 

dokonać modyfikacji adresu IP węzła typu host oraz wskazać parametry pracy węzła, które podczas 

symulacji będą zapisywane do plików dziennika (Rys. 7). 

UWAGA! Każda zmiana trybu pracy programu na tryb definiowania topologii i ponowna zmiana trybu 

na tryb określania parametrów urządzeń skutkuje ponownym wygenerowaniem podstawowych 

ustawień węzłów sieci. Ponowne przypisanie adresów IP węzłom sieci może skutkować koniecznością 

zmiany innych ustawień, np. parametrów wywołań aplikacji uruchamianych na poszczególnych 

węzłach sieci. 
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Rys. 6 Dostęp do zaawansowanych ustawień węzła sieci 
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Rys. 7 Wybór parametrów pracy hosta do zapisu w plikach dzienników 

Po zdefiniowaniu parametrów węzłów sieci można przejść do etapu symulacji działania sieci. W tym 

celu program należy przełączyć do trybu symulacji (przycisk R na pasku narzędzi  lub menu 

File->Operating Mode->Run Simulation). Następnie w celu uruchomienia symulacji należy wybrać 

opcję menu Simulation->Run. 

Po zakończeniu obliczeń program powinien automatycznie przełączyć się do trybu odtwarzania i 

wizualizacji wyników (przycisk P na pasku narzędzi ). Można wówczas odtworzyć animację 

pokazującą przepływ danych oraz wykreślić wykresy obrazujące zmiany wybranych parametrów 

pracy sieci w funkcji czasu (Rys. 8). 
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Rys. 8 Wizualizacja wyników symulacji działania sieci - animacja pakietów wraz z wykresem zależności wybranego 

parametru od czasu 
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5 Narzędzia do wizualizacji wyników 
Podczas wykonywania symulacji program automatycznie zapisuje plik z wykazem zdarzeń 

zachodzących podczas działania modelowanej sieci. Plik ten wykorzystywany jest następnie do 

przedstawienia animacji obrazującej działanie sieci. 

Definiując parametry węzłów sieci użytkownik programu może także wymusić zapisywanie 

parametrów pracy wybranych urządzeń, które zostaną zapisane do odpowiednich plików dzienników 

i będą mogły posłużyć do wykreślenia stosownych wykresów. Do parametrów takich można zaliczyć 

np. liczbę utraconych pakietów, liczbę kolizji, przepustowość łączy, itp. 

5.1 Pliki dziennika 
W celu wyświetlenie pliku dziennika zawierające informacje na temat przepływu pakietów w sieci 

należy wybrać menu G_Tools->View Packet Trace (Rys. 9). Opis znaczenia poszczególnych kolumn 

pliku można wyświetlić wybierając menu G_Tools->Show Packet Trace Format. 

 

Rys. 9 Podgląd pliku dziennika z informacjami o wymienianych pakietach danych 

5.2 Odtwarzacz animacji 
Plik z wynikami symulacji wykorzystywane są przez odtwarzacz animacji obrazujących przepływ 

pakietów w sieci (Packet Animation Player) (Rys. 10). Odtwarzacz animacji jest automatycznie 

uaktywniany po przełączeniu programu do trybu odtwarzania wyników symulacji. Animacje mogą 

zostać także włączone podczas wykonywania symulacji działania sieci w czasie rzeczywistym. 



SiST Strona 12 
 

 

Rys. 10 Animacja przepływu danych w sieci (Packet Animation) 

5.3 Monitor wydajności systemu 
Wykresy obrazujące zmienność w czasie dodatkowych parametrów pracy wybranych urządzeń mogą 

zostać wyświetlone po wybraniu menu G_Tools->Plot Graph (Rys. 11). Po pojawieniu się okna 

wykresu należy wybrać menu File->Open oraz wskazać położenia pliku dziennika, z którego chcemy 

wyświetlić dane. 

 

Rys. 11 Przykładowy wykres obrazujący zależność przepustowości hosta w funkcji czasu 
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6 Symulacja działania przykładowej sieci 

6.1 D – Definiowanie topologii sieci 
1. Utworzyć projekt nowej sieci (menu File->New). 

2. Upewnić się, że program jest w trybie rysowania topologii sieci (zaznaczony przycisk D na 

pasku narzędzi  lub menu File->Operating Mode->Draw Topology). 

3. Na pasku narzędzi wybrać symbol routera a następnie kliknąć lewym przyciskiem myszy w 

obszarze roboczym programu. W wyniku tej operacji router powinien zostać dodany do 

topologii sieci a jego symbol powinien być widoczny w obszarze roboczym programu. 

4. Na pasku narzędzi wybrać symbol hosta a następnie kliknąć lewym przyciskiem myszy w kilku 

(tylu, ile elementów typu host chcemy dodać do topologii sieci) miejscach obszaru roboczego 

programu. 

5. Na pasku narzędzi wybrać ikonę połączenia i przytrzymując wciśnięty lewy klawisz myszy 

połączyć ze sobą elementy sieci (np. poszczególne hosty z routerem). W wyniku poprawnego 

wykonania operacji 1÷5 powinna powstać sieć jak na Rys. 12. 

6. Zapisać plik projektu (menu File->Save As). 

 

Rys. 12 Przykładowa topologia sieci składającej się z routera oraz pięciu hostów 

6.2 E – Określanie parametrów elementów sieci 
1. Przełączyć tryb działania programu do trybu edycji parametrów elementów sieci (zaznaczyć 

przycisk E na pasku narzędzi  lub menu File->Operating Mode->Edit Property). W 

wyniku zmiany trybu, dla wcześniej zdefiniowanej sieci zostaną automatycznie 

wygenerowane adresy urządzeń. Adresy te można podejrzeć wskazując niebieskie kwadraty 
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na końcach połączeń pomiędzy poszczególnymi elementami sieci. 

W trybie edycji można ustawić wiele parametrów urządzeń, zdefiniować charakterystykę 

ruchu w sieci, ustawić czas włączenia/wyłączenia urządzeń, itd. Zestaw dostępnych 

parametrów uzależniony jest od rodzaju urządzenia. 

2. Dwukrotnie kliknąć ikonę hosta o adresie IP 1.0.1.2. W polu dialogowym właściwości 

urządzenia wybrać zakładkę Application oraz nacisnąć przycisk Add. W polu Start time wpisać 

wartość 5, Stop time – wartość 50, w polu Command – stcp -p 8000 1.0.2.2 (pomiędzy 5 a 50 

sekundą symulacji urządzenie będzie wysyłało pakiety TCP do stacji o adresie 1.0.2.2). 

3. Dwukrotnie kliknąć ikonę hosta o adresie IP 1.0.3.2. W polu dialogowym właściwości 

urządzenia wybrać zakładkę Application oraz nacisnąć przycisk Add. W polu Start time wpisać 

wartość 15, Stop time – wartość 70, w polu Command – stcp -p 9000 1.0.2.2 (pomiędzy 15 a 

70 sekundą symulacji urządzenie będzie wysyłało pakiety TCP do stacji o adresie 1.0.2.2). 

4. Dwukrotnie kliknąć ikonę hosta o adresie IP 1.0.2.2. W polu dialogowym właściwości 

urządzenia wybrać zakładkę Application oraz nacisnąć przycisk Add. W polu Start time wpisać 

wartość 0, Stop time – wartość 100, w polu Command – rtcp -p 8000. Ponownie nacisnąć 

przycisk Add. W polu Start time wpisać wartość 0, Stop time – wartość 100, w polu Command 

– rtcp -p 9000 (urządzenie będzie odbierało pakiety TCP na portach 8000 oraz 9000). 

5. Zapisać zmiany w projekcie. 

6.3 R – Wykonywanie obliczeń 
1. Przełączyć tryb pracy na tryb symulacji działania sieci (zaznaczony przycisk R na pasku 

narzędzi  lub menu File->Operating Mode->Run Simulation). 

2. Sprawdzić ustawienia programu dispatcher. Wybrać menu G_Setting->Dispatcher w oknie 

dialogowym w polu IP address powinna być wpisana wartość 127.0.0.1 a w polu Port wartość 

9800 (Rys. 13). 

 

Rys. 13 Ustawienia programu dispatcher 
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3. Uruchomić obliczenia wybierając menu Simulation->Run. W wyniku poprawnego 

uruchomienia symulacji, licznik czasu widoczny w dolnej części interfejsu programu powinien 

wskazywać postęp obliczeń. Szybkość symulacji działania sieci może odbiegać od czasu 

rzeczywistego. Więcej parametrów dotyczących szybkości wykonywania obliczeń można 

ustawić po wybraniu menu G_Setting->Simulation->Speed. 

6.4 P – Przeglądanie wyników działania programu – narzędzia do 
wizualizacji wyników 

1. Po zakończeniu symulacji program powinien automatycznie przejść do trybu odtwarzania 

wyników. W razie potrzeby zmienić tryb pracy programu (zaznaczony przycisk P na pasku 

narzędzi  lub menu File->Operating Mode->Play Back). 

2. Korzystając z przycisków sterowania umieszczonych w dolnej części ekranu odtworzyć 

przebieg działania sieci. Dane zapisane w pliku .ptr (Packet Animation Trace) zostaną 

przedstawione w postaci animacji prezentującej wymianę danych pomiędzy poszczególnymi 

węzłami sieci (Rys. 10). 

3. Wybrać menu G_Tools->View Packet Trace oraz wskazać plik .ptr o nazwie odpowiadającej 

nazwie projektu w celu wyświetlenia zawartości pliku. Poszczególne wiersze przedstawiają 

kolejne zdarzenia, jakie zaszły podczas symulowanego okresu działania sieci (Rys. 9). 
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7 Symulowanie awarii urządzeń 
Symulator NCTUns umożliwia badanie zachowania sieci w sytuacji wystąpienia awarii wybranych 

urządzeń. W celu zamodelowanie scenariusza, w którym awarii ulega jeden z elementów sieci należy 

przełączyć program do trybu edycji parametrów węzłów sieci (E). Następnie po wskazaniu kursorem i 

dwukrotnym kliknięciu lewym przyciskiem myszy ikony węzła sieci (lub łącza pomiędzy wybranymi 

węzłami) można określić przedziały czasu symulacji, w których urządzenie będzie pozostawało 

nieaktywne (sekcja Down time, nacisnąć przycisk Add a następnie podać początek i koniec przedziału 

czasu)  (Rys. 14). 

 

Rys. 14 Ustawianie czasu, w którym łącze pozostaje nieaktywne 
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8 Symulacje w czasie rzeczywistym 
Jedną z opcji udostępnianych przez program NCTUns jest możliwość wykonywania symulacji działania 

sieci w czasie rzeczywistym. Zaletą takiego podejścia jest możliwość zalogowania się do wybranego 

węzła sieci i wydawania w trakcie trwania symulacji komend (np. ping, tcpdump, traceroute, ifconfig, 

route, netstat) z poziomu modelowanego urządzenia. W tym trybie można także włączyć animację 

pakietów podczas trwania symulacji. 

W celu włączenia trybu symulacji w czasie rzeczywistym należy wybrać menu G_Tools->Simulation 

wybrać zakładkę Speed oraz zaznaczyć opcję As fast as the real-world clock (Rys. 15). 

 

 

Rys. 15 Włączanie trybu symulacji w czasie rzeczywistym 

W celu uruchomienia konsoli poleceń wybranego węzła sieci należy podczas trwania symulacji 

wskazać kursorem wybrane urządzenie a następnie dwukrotnie kliknąć lewym przyciskiem myszy. 

Następnie należy w oknie dialogowym wybrać przycisk Command console (Rys. 16). Po wykonaniu tej 

operacji powinno pojawić się okno terminala umożliwiającego wykonywanie poleceń z poziomu 

wybranego węzła sieci (Rys. 17). 
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Rys. 16 Uruchamianie konsoli poleceń podczas trwania symulacji 

 

 

Rys. 17 Wykonywanie poleceń systemowych podczas trwania symulacji 
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9 Ćwiczenia do wykonania pomagające zapoznaniu się z programem 
1. Zapoznać się z dostępnymi w programie modelami podstawowych urządzeń sieciowych 

(koncentrator, przełącznik, router, host, podsieć, łącze punkt-punkt). Zmodyfikować 

utworzony wcześniej model sieci, tak aby zawierał wymienione komponenty. Sprawdzić, jakie 

parametry można ustawić w przypadku poszczególnych komponentów. 

2. Dla wybranej pary hostów przećwiczyć definiowanie ustawień generatorów ruchu (stcp, rtcp, 

stg, rtg, rtp, rtcp). 

3. Sprawdzić jakie parametry podstawowych węzłów sieci można monitorować i zapisywać w 

plikach dzienników. Dla przykładowego węzła (np. hosta) przećwiczyć korzystanie z narzędzia 

do kreślenia wykresów. 

4. Uruchomić symulację działania prostej sieci w czasie rzeczywistym. Zalogować się do 

wybranego hosta. Przećwiczyć korzystanie z okna komend (wykonać przykładowe polecenia, 

np. ping). 

5. Zapoznać się z przykładowymi projektami (/home/nctuns/Pobrane/nctuns-6.0/examples/). 

Mogą one stanowić podstawę do budowy własnych projektów sieci. 
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