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Celem ćwiczenia jest: 

 zapoznanie się z podstawowymi funkcjami programu Radio Mobile 

 poznanie czynników wpływających na zasięg nadajnika bezprzewodowego. 

 

1. Literatura: 
1. K. Wesołowski, Systemy radiokomunikacji ruchomej, WKiŁ 2006 

2. RECOMMENDATION ITU-R BS.412-9 Planning standards for terrestrial FM sound 

broadcasting at VHF 

 

2. Zakres ćwiczenia. 
 

 Zakres ćwiczenia obejmuje zapoznanie się ze sposobem analizy zasięgu nadajnika FM 

za pomocą programu Radio Mobile.  

 Obszar objęty zasięgiem nadajnika to obszar, w którym stacja bazowa może 

komunikować się z odbiornikiem. Minimalnym wymogiem udanej transmisji w systemie 

radiokomunikacji rozsiewczej FM (transmisja jednokierunkowa) jest zapewnienie 

odbiornikowi odpowiedniej energii odbieranego sygnału [1]. Jest to określone przez wartość 

mediany natężenia pola elektrycznego w którym znajduje się odbiornik i podane w 

odpowiednim zaleceniu ITU-R dla konkretnego systemu bezprzewodowego. 

W tym ćwiczeniu zastosujemy rekomendację ITU-R dla emisji dźwięku FM w paśmie 

VHF [2]. Definiuje ona minimalną użyteczną wartość natężenia pola elektrycznego 

generowanego przez nadajnik w odniesieniu do jego mediany mierzonej na wysokości 10 m 

powyżej poziomu gruntu. Dla symulacji zasięgu nadajnika zakładamy, że antena odbiornika 

znajduje się 10 m nad ziemią. 

 Symulując zasięg systemu należy przyjąć minimalne wartości natężenia pola podane 

w tabeli 1. 
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Tab. 1. Minimalne wartości natężenia pola do symulacji zasięgu systemu FM [2] 

 

 
 

 

3. Program Radio Mobile 

 
Program Radio Mobile jest darmowym programem opracowanym przez Rogera Coudé, 

umożliwiającym przeprowadzenie symulacji zasięgów systemów bezprzewodowych. Na 

stronie http://radiomobile.pe1mew.nl znajduje się wiele informacji dotyczących tego 

projektu. Program Radio Mobile wykonuje symulacje z wykorzystaniem modelu 

propagacyjnego Irregular Terrain Model - ITM. Model nieregularnego terenu (ITM), znany 

również jako model Longley-Rice, umożliwia wyznaczenie średniego tłumienia trasy dla 

transmisji dalekiego zasięgu sygnału radiowego z uwzględnieniem  warunków 

atmosferycznych i geograficznych. 

Program w wersji instalacyjnej jest dostępny na stronie:  

http://radiomobile.pe1mew.nl/?Installation 

 
Aby zrealizować ćwiczenie należy zainstalować program zgodnie z instrukcją podaną na 

stronie projektu. Konieczne jest pobranie pliku „rmwcore.zip”, a następnie pakietu 

językowego ze strony http://www.ve2dbe.com/download/download.html. W instrukcji podaję 

nazwy menu programu z zainstalowanym pakietem j. angielskiego. Pobrane pliki należy 

rozpakować do folderu instalacyjnego. 

 

W najprostszym wariancie instalacji programu nie jest konieczne samodzielne pobieranie map 

cyfrowych terenu i kopiowanie ich do folderu programu. Program uruchomiony z 

domyślnymi ustawieniami będzie pobierał mapy z ogólnie dostępnych serwisów sieciowych 

(np. google). Konieczny jest wtedy dostęp do Internetu podczas pracy z programem.  

 

Aby program automatycznie pobierał potrzebne mapy z Internetu, należy zmodyfikować plik 

„Map_Link.txt”, który znajduje się z folderze instalacyjnym programu. Z pliku należy usunąć 

apostrofy ‘ znajdujące się w początkowych liniach.  

 

Po zmodyfikowaniu pliku „Map_Link.txt” należy uruchomić program i sprawdzić czy jest 

ustawiona opcja automatycznego pobierania map z Internetu. W oknie „Internet Options” 

należy zaznaczyć opcję „Download from Internet …” przy wszystkich rodzajach danych: 

SRTM, Land cover, OpenStreetMap, NationalMap, Toporama, Virtual Earth, Google Map: 

 

http://radiomobile.pe1mew.nl/
http://radiomobile.pe1mew.nl/?Installation
http://www.ve2dbe.com/download/download.html
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4. Przebieg ćwiczenia 
 

1.  Utworzenie projektu w programie Radio Mobile 

 

Program w wersji angielskojęzycznej uruchamiamy plikiem rmweng.exe. Następnie klikamy 

na przycisk „Map Properties”: 

 

 
 

Następnie wybieramy miasto Łódź, wokół którego przeprowadzona zostanie analiza. Lista 

miast dostępna jest po naciśnięciu przycisku „Select a city name”. Następnie wpisujemy „Lo” 

i wybieramy z listy Lodz.  
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Rozmiar mapy w pikselach (Size(pixel)) ustalamy na Width =1200, Height = 700 pixel. Do 

tak zdefiniowanej mapy w pikselach możemy przyporządkować odpowiedni obszar trenu. 

Rozmiar analizowanego obszaru w kierunku pionowym na mapie ustalamy na 100 km (Size 

> Height > 100 km). Następnie naciskamy przycisk „Extract”. 

 

Zaprezentowana zostanie mapa odwzorowująca wysokość terenu nad poziomem morza, 

której wycinek prezentuję poniżej: 

 
 

Mapa wysokościowa jest bardzo istotna w przypadku projektowania systemów 

bezprzewodowych ponieważ ukształtowanie terenu ma duży wpływ na zasięg nadajników. 
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Projektant powinien zawsze zapoznać się z rozkładem wysokości na obszarze, na którym 

projektuje system.  

 

Na mapie wysokościowej możemy wyświetlić warstwę z naniesionymi drogami i nazwami 

miejscowości, co znacznie ułatwia orientację w projekcie. W tym celu należy skorzystać z 

menu: Edit > Merge pictures, lub nacisnąć poniższy przycisk: 

 
 

Z okna Merge pictures wybieramy Source > Internet VirtualEarth, oraz Virtual Earth > Roads: 

 
 

W przypadku zaznaczenia opcji Copy, warstwa dróg i nazw miejscowości zastąpi mapę 

wysokościową. Pozostałe opcje nakładają obie mapy. Nałożenie zostanie dokonane po 

naciśnięciu przycisku Draw. 

Tak skonfigurowana mapa może nadpisać istniejącą, lub powstać jako nowy obiekt. Aby 

nadpisać istniejąca zaznaczamy „Keep in actual picture”: 

 

 
 

Przykładowy Wycinek mapy z naniesionymi drogami i nazwami miejscowości wygląda 

następująco: 
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2. Konfiguracja systemu nadawczego 

 

Parametry systemu transmisyjnego należy skonfigurować w menu File > Networks properties: 

 

 
 

Następnie w oknie „Network Properties” zaznaczamy w lewym panelu nazwę sieci Net 1  i 

definiujemy jej parametry, jak pokazano w oknie poniżej. Nazwę sieci definiujemy jako (Net 

name): FM Broadcast, Zakres częstotliwości 87 – 107 MHz, rodzaj analizy (Mode variability) 

Broadcast. 

 

 
 

W zakładce „Memebership” zaznaczamy, które stacje bazowe (jeszcze nie 

zdefiniowane) należą do wybranego systemu. Zaznaczamy 1 i 2. 



 

 

Ćwiczenie 1. Analiza zasięgu nadajnika FM  7 

 

 
 

W zakładce Systems  określa się bardzo istotne parametry systemu nadawczego. 

Nalężą do nich m.in. moc nadajnika (Transmit power), czułość odbiornika (Receiver 

treshold), domyślna wysokość zawieszenia anten (Antenna height), zysk energetyczny 

anten (Antenna gain). Wstępnie należy wpisać poniższe wartości. Dla systemu FM, 

wybieramy domyślną wysokość anteny 10m. 
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3. Symulacja zasięgu stacji bazowej 

 

W wybranym miejscu na mapie, w którym ma zostać zlokalizowana stacja bazowa należy 

ustawić kursor i kliknąć lewym klawiszem myszy.  Początkowo należy wybrać centrum 

miasta. 

 
 

Następnie z menu File opcję  Unit properties  

 
 

W oknie „Units properties” definiujemy stacje bazowe i terminale. Zaznaczamy Unit 1 w 

lewym panelu i nadajemy mu nazwę > Name > „Transmitter”. Następnie należy nacisnąć 

przycisk „Place unit at cursor position”  i potwierdzić przyciskiem OK. 

 

 

 
 

 

Tak zdefiniowany został nadajnik. 

Następnie ustawiamy gdziekolwiek na mapie kursor, i definiujemy kolejny obiekt (Unit2) jak 

to opisano powyżej, nadając mu tym razem nazwę Name > „Receiver”. 
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Przed wykonaniem symulacji możemy dokonać konwersji mapy na skalę szarości, co ułatwi 

analizę danych symulacyjnych. W tym celu z menu Edit wybieramy > Force gray scale: 

 

 
 

Wybieramy opcję „Keep in a new picture”. Dzięki temu powstanie mapa, na której będziemy 

mogli wykreślać za każdym razem nowe wyniki symulacji.  

 

 
 

Symulację zasięgu pojedynczego nadajnika możemy przeprowadzić wybierając z menu Tools 

> Radio coverage > Single polar: 

 
 

Wybieramy jako Centre Unit  stację, której nadaliśmy wcześniej nazwę Transmitter. W tym 

celu wybieramy z listy Centre Unit > Transmitter. Symulacje wykonane zostaną dla 

odbiornika który traktowany jest jako terminal mobilny, który może znajdować się w różnych 

położeniach na mapie. W tym celu wybieramy z listy Mobile Unit > Receiver. Symulacje 

przeprowadzone zostaną dla, każdego punktu wokół nadajnika w promieniu od „Radial range” 

minimum = 0,01 km do Maximum = 50 km.  

Dane uzyskane w wyniku symulacji zostaną wykreślone tylko dla zdefiniowanego przedziału 

wartości, który możemy kontrolować. W programach do projektowania systemów radiowych 

wyświetla się obszary, w których natężenie pola elektrycznego w [dBV/m] (bądź moc 

odebrana [dBm]) jest nie mniejsze niż minimalne zapewniające działanie systemu. Dla 

systemów FM wybieramy zakres: Threshold > dBV/m > from 54 to 74, ponieważ minimalna 

wartość natężenia pola, która określi zasięg systemu to 54 dBV/m. 

Zaznaczamy Plot> Fill Area, Solid, Rainbow aby wykreślić mapę która koduje natężenie pola 

barwami. 
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Wygodnie jest wynik symulacji wykreślić jako nowy obraz (Keep in a new picture). Można 

wtedy łatwo porównać wyniki otrzymane dla różnych wariantów systemu. 

 

 
 

Wycinek utworzonej nowej mapy z zasięgiem wygląda następująco: 

 

 
 

Kolory na tej mapie wskazują zasięg nadajnika czyli obszary, na których możliwy będzie 

odbiór sygnału z nadajnika (natężenie pola elektrycznego jest większe niż minimalne 

wymagane do odbioru, co podano w tabeli 1). 
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W celu symulacji zasięgu nadajnika ze zmienionymi parametrami należy wrócić do okna 

mapy w skali szarości. Można na niej wyświetlić położenie stacji za pomocą przycisku „Show 

networks”: 

 
 

Aby przeprowadzić symulację zasięgu nadajnika o zmienionych parametrach należy dokonać 

zmian w menu File > Network properties. Aby zmienić wysokość zawieszenia anteny, 

wybieramy w zakładce Membership > Transmitter i zmieniamy Antenna Height z „System” 

na „Other” i wpisujemy wartość 30. 

 

 
 

 

Następnie wybieramy utworzoną wcześniej mapę prezentującą drogi i miejscowości w skali 

szarości.  

Symulację przeprowadzamy wybierając z menu Tools > Radio coverage > Single polar, tak 

jak to opisano powyżej.  

 

Zasięg nadajnika z anteną zawieszoną 30 m nad ziemią jest następujący: 
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4. Analiza czynników wpływających na zasięg stacji bazowych (zadania do 

samodzielnej realizacji) 

 

a. Badanie parametrów nadajnika na zasięg systemu 

 

Należy zbadać wpływ każdego z parametrów nadajnika na jego zasięg.  W tym celu należy 

zmienić wartości poniższych parametrów i zarejestrować zmiany zasięgu nadajnika: 

 Transmitter power - (menu File>Networks properties > zakładka Systems) 

 Antenna gain - (menu File>Networks properties > zakładka Systems) 

 Antenna height (menu File>Networks properties > zakładka Membership) 

Wybieramy Other i wpisujemy wysokość w m dla zaznaczonego 

nadajnika. 

 

W sprawozdaniu należy zamieścić wyniki symulacji ilustrujące zależność zasięgu nadajnika 

od powyższych parametrów. 

 

b. Badanie wpływu ukształtowania terenu na zasięg nadajnika. 

 

Należy utworzyć nowy projekt z mapą, w której środku znajduje się Zakopane (np. wejście 

na szlak niebieski 49.2694, 19.9805). W oknie „Map Properties” należy wprowadzić 

współrzędne środka mapy. Wysokość mapy powinna wynosić 50 km. 
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Mapa zwierać będzie tereny górskie. Należy umieścić stację bazową u podnóża 

wybranej góry, kolejną na jej zboczu i kolejną na szczycie. Następnie należy porównać 

zasięgi tak usytuowanych nadajników przeprowadzając symulacje zasięgów każdego 

nadajnika z osobna, dla różnych wysokości zawieszenia anten.  

 

c. Badanie wpływu zabudowy na zasięg nadajnika. 

 

Kolejne symulacje należy przeprowadzić wykorzystując mapę, na której znajduje się 

duże miasto położone na równinie wraz z jego otoczeniem. Wybór miasta jest dowolny. 

Sugerowana wysokość mapy to 100 km. Na tak przygotowanej mapie należy umieścić stację 

bazową w obszarze przedmieścia, kolejną w centrum miasta i następną poza miastem. 

Dla nadajników w obszarze miasta należy zastosować właściwe wartości minimalnego 

natężenia pola (minimum field strength) zgodnie z tabelą 1 (Tools > Radio coverage > Single 

polar > Threshold > dBV/m).  

Następnie należy porównać zasięgi tak usytuowanych nadajników przeprowadzając 

symulacje zasięgów każdego nadajnika z osobna, dla różnych wysokości zawieszenia anten. 

 

W sprawozdaniu należy zamieścić niezbędne wyniki symulacji, na podstawie których należy 

określić w jaki sposób czynniki opisane w punktach a-c wpływają na zasięg systemu 

bezprzewodowego. 
 

 

 


