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1 NCTUns Program In General

NCTUns Program is an extensible network simulator and emulator for teleinformatic networks.
NCTUns directly uses the real-life Linux’s TCP/IP protocol stack to generate high-fidelity simulation
results. By using the novel kernel re-entering simulation methodology, a real life UNIX kernel’s
protocol stack is directly used to generate high-fidelity simulation results. In NCTUns, all real-life
existing or to-be-developed UNIX application programs can be run up on a node in a simulated
network. In NCTUns, the configuration and operation for a simulated network are exactly the same
as those for a real-life IP network.

NCTUns simulates Ethernet-based IP networks with fixed nodes and point-to-point links. It simulates
IEEE 802.11 (a)(b) wireless LAN networks, including both the ad-hoc and infrastructure modes. It
simulates GPRS cellular networks. It simulates optical networks, including traditional circuit switching
optical network and more advanced optical burst switching (OBS) networks and many more...
NCTUns simulates various protocols such as IEEE 802.3 CSMA/CD MAC, IEEE 802.11 (a)(b)(e)(p)
CSMA/CA MAC, the learning bridge protocol used by switches, the spanning tree protocol used by
switches, IP, Mobile IP, RIP, OSPF, UDP, TCP, HTTP, FTP, Telnet, etc. It simulates the DiffServ QoS
protocol suite, the optical light-path setup protocol, the RTP/RTCP/SDP protocol suite. It simulates
the IEEE 802.16(d)(e)(j) WiMAX PMP protocol suites and the 802.16(d) mesh mode protocol suite,
and DVBRCST.

A user may add his/her own protocol thanks to the open structure.

2 NCTUns - Getting Started
To start the work with NCTUns the student should::

- log in as the user student (password: telekomunikacja — IN POLISH!);
- start Sun VirtualBox program;

- select Fedoral2 virtual engine and start it by pressing Uruchom button(Fig. 1);

- When Fedora system is starting a window appears with selecting the system kernel; then the student
should select the option: NCTUns (2.6.31.6-nctuns20091227) and confirm by Enter (Fig. 2);

- When the system is on, LOG IN as the user nctuns (password: nctuns);

- Before starting NCTUns klient program one should start dispatcher and coordinator programs,
which are in /usr/local/nctuns/bin/ directory. To make this one should start terminal (its
abbreviation is on the board screen) and perform the command: ./run_nctuns;

- then one can start nctunsclient program that is in /usr/local/nctuns/bin/ directory. Its
abbreviation is on the board screen;

- When the above steps are completed correctly the GUI of NCTUns program appears (Fig. 3).
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3 Basic Elements of NCTUns program GUI

NCTUns program GIU consists of following elements:

- menu that allows to enter into program functions (Fig. 4 — M);

- tool bars that allow, among others, to define a network topology (icons represent different
device classes) or to change the active mode of the program (Fig. 4 — PN);
- work area, where the topology of the analysed network is defined (Fig. 4 — OR);

- status bar, where the information on the run simulation is placed together with press-buttons
to control the replay of the simulation results. (Fig. 4 — ST).
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4 Starting the work with NCTUns program

The projekt work consists of four stages, with them suitable program modes are connected:

- stage No. 1 — network topology editor (D button on the tool bar P E R Pl or in menu: File-
>Operating Mode->Draw Topology);

- stage No. 2 - Attribute Dialog Box (E button on the tool bar ® E R Plorin

menu File->Operating Mode->Edit Property);

- stage No. 3 - simulation of the network work (R button on the tool bar P E R P|or in menu File-
>Operating Mode->Run Simulation);

- stage No. 4 — animation plater and simulation results’ visualisation ( P button on the tool bar
D E R Plorin menu File->Operating Mode->Play Back).

To open any existing project — one should select menu File->Open and then indicate the project file
(.tpl).

To make a new network project — one should select menu File->New. When the new project is
initiated, an empty work area appears in the screen, when elements of the modeled network can be

put. Make sure that the valid mode is Topology Editor (D button on the tool bar P E R P|or in menu
File->Operating Mode->Draw Topology) and then select a network element from the tool bar, show
the place in the work area with the cursor and press the mouse left button (left-click).

When the topology is defined, the user may enter the next stage where node attributes must be
determined. To make this, the program mode must be changed into Editing Nodes’ Properties (E

button on the tool bar P E R Pl or in menu File->Operating Mode->Edit Property). When changing
the mode the program will ask to indicate the file localization and the name for the project and
generate the basic settlements for the network, in these IP addresses for the devices. In this mode
one can determine more advanced parameters of the devices’ operation, as for example:

— delays and error bit rates in transmitting links;

— applications (traffic generators) operating on indicated nodes;
— routing protocols;

— buffer sizes;

— work parameters to be saved in log files;

— on and off limes of devices;

Editing network nodes’ properties can be done in two steps. In the first step, a user can use
the mouse to double-click a node’s icon. A dialog box will appear in which a user can set
parameter values or option values (Fig. 5).
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Fig. 5 The window to define node parameters — In this example: host — defining applications (traffic generators setting)

Then the user may double-click the Node editor in the dialog box to hale the access to more
advanced setting (Fig. 6). For example by selecting the MAC 802.3 layer box, one can modify
IP address of the host and indicate the node work parameters to be saved in log files during
the simulation (Fig. 7).

WARNING! Each change of the work modes from editing topology to properties and back, results in
generating basic settings of the network from the beginning. As new IP addresses are attributed to
the nodes, some other settings may need being changed as well, for example parameters of
applications on some nodes.
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Fig. 7 Selecting work parameters of host to save in log files

When a user finishes editing the properties of network nodes and specifying application programs to
be executed during a simulation, he (she) can start to run the simulation. To do so, the user must
switch the mode explicitly from “Edit Property” to “Run Simulation.” (R button on the tool bar

or in menu File->Operating Mode->Run Simulation). Entering this mode indicates that no
more changes can (should) be made to the simulation case, which is reasonable. The simulation is
about to be started. At this moment, of course, no settings should be changed.

After the simulation is finished, the simulation server will send back the simulation result files to the
GUI program and will then automatically switch to the “Play Back” mode (P button on the tool bar

D E R P)). Then one can open the animation that shows the data flow and plot graphs with selected
parameters of the network work parameters versus time (Fig. 8).
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Fig. 8 Visualization of the simulation results — packet animation with the graph of a chosen parameter function versus time
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5 Tools to Visualize The Results

During simulation the result file generated by the simulation engine with the events’ list is
stored automatically. This file is used for the animation to demonstrate the network work then.

When the user defines the network nodes’ parameters, he/she may force recording work
parameters of selected devices to be stored in suitable log files and being ready to be used in graphs.
Here one has the number of lost packets, the number of collisions, link bandwidth etc.

5.1 Log Files

To display the log file that consists information on the packet transfer within the network one should
choose the menu G_Tools->View Packet Trace (Fig. 9). One can see the meaning of successive
columns by the menu G_Tools->Show Packet Trace Format.
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Fig. 9 Log file with information on changed packets of data

5.2 Animation Player

Files with simulation results are used by the animation player that shows the flow of packets in
the network (Fig. 10). The player is activated automatically when the program is switched to the
simulation results replay mode. The animations may be also switched on when the simulation is
running in real time.
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Fig. 10 Packet Animation of data flow in the network

5.3 Performance Monitor

A user can execute the Menu menu G_Tools->Plot Graph (Fig. 11) command to launch the
performance monitor. From the performance monitor window, a user can select (menu File->Open)

a desired log file to open.
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Fig. 11 Example graph with the host bandwidth dependence versus time
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6 Emulation of An Example Network Operation

6.1 D - Defining network topology

1. Create a New network project (menu File->New).

2. Make sure that the valid mode is Drawing (D button on the tool bar is marked DERPlorin
the menu File->Operating Mode->Draw Topology).

3. Select the router symbol on the tool bar and left-click in the work area of the program. As the
result the router should be added to the topology and its symbol should be visible in the
work area.

4. Select the host symbol on the tool bar and left-click in several (as many times as many hosts
one wants to add to the network topology) places in the work area.

5. Select the link icon on the tool bar and keeping the mouse left button pressed, connect
network elements one to the other (for example successive hosts with router).

As the result of 1+5 steps the network as in Fig. 12 is visible.

6. Save the project file (menu File->Save As).
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Fig. 12 Example topology of the network that consists of one router and five hosts

6.2 E - Editing parameters of networks elements
1. Switch the program mode into edit property (mark E button on the tool bar OERPFlorin
menu File->Operating Mode->Edit Property). At the moment of modes’ switching devices
addresses will be generated automatically for the defined network. They can be seen when
one indicates blue boxes on the links’ terminals between successive elements. One can set
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many parameters of the devices in this mode, define the traffic characterization, set on and
off times, etc. The set of possible parameters depends on a given device type.

Double click on the host icon with the IP address 1.0.1.2. In the dialog box choose
Application and press Add button. Write ‘5’ in the box Start time and in Stop time — ‘50, in
Command — stcp -p 8000 1.0.2.2 (within 5 and 50 second of the simulation the device will
send TCP packets to the station addressed 1.0.2.2).

Double click on the host icon with the IP address 1.0.3.2. In the dialog box of the device
properties choose Application and press Add button. Write ‘15’ in the box Start time and
in Stop time — ‘70, in Command — stcp -p 9000 1.0.2.2 (within 15 and 70 second of the
simulation the device will send TCP packets to the station addressed 1.0.2.2).

Double click on the host icon with the IP address 1.0.2.2. In the dialog box of the device
properties choose Application and press Add button. Write ‘0’ in the box Start time and in,
Stop time —“100’, in Command — rtcp -p 8000. Press Add button again. In Start time write
‘0’, and in Stop time —‘100’, in Command — rtcp -p 9000 (the device will receive TCP packets
on 8000 and 9000 ports).

Save the changes in the projects.

6.3 R - Calculations

1. Switch the mode to the emulation of the network (mark R button on the tool bar 2 E R Plor
in the menu File->Operating Mode->Run Simulation).
2. Check dispatcher settings. Select menu G_Setting->Dispatcher the value 127.0.0.1 should be
visible in the IP address box in the dialog window and the value 9800 in Port (Fig. 13).
el =
—Job dispatcher
IP address |12?| ’{r lﬂ Il Port IBEDD
—Liser information
Lser name In@tun;s Password I******
Email address I
The user name here cannot be "root". Otherwise, the
command console function cannot work correctly.
Ok | Cancel
Fig. 13 Dispatcher settings
3. Start calculations in the menu Simulation->Run. When the simulation is started correctly the
time counter in the bottom part of the interface should show the progress of calculations.
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The speed of the simulation may vary from the real time. More parameters relating to the
speed of calculations may be set in the menu G_Setting->Simulation->Speed.

6.4 P - Looking At The Results - Tools To Visualize

1. When the simulaion is completed, the program should switch automatically to play back

SiST

mode. When required one may change the mode (mark P button on the tool bar P E R Flor
in the menu File->Operating Mode->Play Back).

Using control buttons placed in the bottom parto f the screen, one may play back the
network operation. Data that is saved in the .ptr file (Packet Animation Trace) will be showed
as the animation presenting the data exchange among successive nodes (Fig. 10).

Select menu G_Tools->View Packet Trace and indicate.ptr file named with the same name as

the projekt, to put its cotent to the screen. Successive lines show successive events that
occurred during the simulated period of operation (Fig. 9).
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7 Simulating The Devices’ Failures

NCTUns Simulator makes possible testing the network behavior when a failure of the selected
device happens. To model such a scenario, that one of the elements fails, one should switch to the
edit mode (E). Then he/she should indicate the node or the link with the cursor and double left-click.
The ranges when the device is inactive during the simulation can be defined (Down time section,
press Add and indicate start and stop times of the range (Fig. 14).

—From Hosi2 to Router1 From Router1 to Host2
Delay [1.00 CTAL | CTAC | Dalay: 1.00 CTAL | CTAC |
{us) (us}
Bandwidth: S Bandwidth: M =
[10.00 Mbps) CTAL | cTAc| 1000 (Mbps) crag | crac|
BER [o.0000000000 caall| crac| | BER: [0.0000000000 cral| erac|
—Down time Down time

Start (s} End (s) Start (s) End (s)

20.00 40.00

C.T.A.L | C.T.AL |

(oK _cancel |

Fig. 14 Setting the inactive time of the link
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8 Real Time Simulations

Among the options of NCTUns program there is a possibility performing the network simulation
in redl time. The advantage of such a simulation is that one can log in to the selected node and
give commands during the time when the simulation is on (for example ping, tcpdump,
traceroute, ifconfig, route, netstat) from the level of the modeled device. Also the packet
animation may be switched on during this mode.

To switch the mode into redl time one should choose menu G_Tools->Simulation then Speed and
mark the option As fast as the real-world clock (Fig. 15).

)]

i
4
—i

-
Simulation | Speed

One tick 100 | nanoseco|

-Simulation Speed

+ As fast as possible

As fast as the real-world clock
“% (This speed must be selected for an emula
However, it can also be used for a simulati

Fig. 15 Switching the real time simulation on

To start the command console for the selected node, indicate it with the cursor (when the simulation
is on) and double left-click. Then choose the Command console button in the dialog box (Fig. 16). The
terminal window should appear, which enables to execute commands from the chosen node level
(Fig. 17).
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19000000 24000000 s1g -u 1400 50 1.0.6.2 Modlty |
000000 100.000000 stop p B000 1.0.6.2

22.000000  24.000000 stcp-p 8040 1.0.6.2 Add RTP

Madify RTP

Delete

i

Commang consdle | Nodeedtor || ok | cancel |

Fig. 16 Starting the command console when the simulation is on
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them to appear in ¥¥¥.results dir, these files must be generated in this dir, II I ‘ ‘ ‘ '- ' ! |

NODE: 2

[retuns@localhost “1$ ping 1,0,4,1 F1

B4 bytes from 1,0,4 icnp_seq=l tt1=62 time=E1,8 ms m & L L ‘ L L ‘

B4 bytes from 1,0.4 icmp_: 2 ttl=62 time=£9,8

B4 bytes from 1,0.4

B4 bytes from 1,0.4

64 bytes from 1,0.4

B4 bytes from 1,0.4

B4 bytes from 1,0.4

B4 bytes from 1,0.4,
1,0.4
1.0.4
1.0.4
1.0.4
1.0.4
1.0.4
1,0.4

L1 Y]
L8 L1LELLE
; .‘ﬂ|§§|/@@s&&§.$§-|ﬁ\lERP|

=

=

3 tt1=62 time=60,5
icmp_seq=4 ttl=62 time=60,7
icmp_seq=h ttl=62 time=66,5 ms
icmp_seq=7 ttl=62 time=4,95. ms

i &
;- icmp_seq=8 ttl=62 time=81.5. = — I
1 icmp_seq=3 tt1=62 time=61,3 m= o572

1 icmp_seq=10 ttl=62 time=58.8 ms

=

=

=3

=

===

B4 bytes from
B4 bytes from
B4 bytes from
B4 bytes from
B4 bytes from

icmp_seq=ll tt1=62 time=60.9 ms
icmp_seq=12 tt1=62 tine=52.0 ms |
icmp_seq=13 ttl=62 time=0.507 ms

- icmp_zeq=14 ttl=62 time=0.516 ms
B4 bytes from icmp_seq=15 ttl1=62 time=0.511 ms Ilrput file n Add

B4 bytes from 1, icmp_zeq=16 ttl=E2 time=0,51E mz

- 1.0.4,1 ping statistics - 50 1.0.6.2 Modify

16 packets transmitted. 15 received. i packet loss, time 15801ns
rttmindsuginaxmdey = 0,507/42 RES/ED, BEA/2D, 330 ne 10 1.0.6.2

[hctunsBlocalhost 1% 10 1.0.6.2 Add ATP
Modify RTP
Delete

App. Usage

R
L p]

Command console | Node editor | OK | Cancell

< I - = -
0005000 B4 0 HQ @_’H > 1l @ Pffors *_toon |

| Node 1D: 2 [(253.-190) %
] ]

= [root@lacalhostifusril... || [ [nctuns@localhostyu... |[ ] NCTUns 6.0 version (... || =] nctuns

Fig. 17 Executing the system commands when the simulation is on
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9 Examples of experiments to be made which help to familiarize with the
software

1.

SiST

Get acquainted with accessible models of basic devices (hub, switch, router, host, sub-
network, point-to-point link). Modify the network model made before with these
elements. Check what parameters can be set for successive components.

Test traffic generators defining for a selected pair of hoss (stcp, rtcp, stg, rtg, rtp, rtcp).

Check what parameters of basic notes may be monitorem and saved in log files. Try the grach
tool for any node (for example a host).

Switch the real time simulation for a simple network. Log in to a chosen host. Test using the
command window (perform example commands, as ping).

Get acquainted with example projects (/home/nctuns/Pobrane/nctuns-6.0/examples/).
They may serve as the base to build own network projects.
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